The issue has been resolved. Our apologies for the inconvenience.
Posted Mar 30, 2025 - 13:29 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2025 - 09:59 CEST
Investigating
We are currently experiencing significant delays in our website response time. We are currently investigating the cause of this issue. You can expect daily status updates or as soon as new information is available. Our apologies for the inconvenience.
Posted Mar 28, 2025 - 17:01 CET
This incident affected: Exact Online Fiscaal and Exact Online Jaarrekening.