Dashboards are not working properly
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Dec 10, 2020 - 17:21 CET
Investigating
We are currently investigating this issue.
Posted Dec 10, 2020 - 17:16 CET