This issue has been resolved. All bank statements are delivered. Our apologies for the inconvenience.
Posted Sep 12, 2025 - 19:31 CEST
Monitoring
Codabox has implemented a fix and are monitoring the results.
Posted Sep 12, 2025 - 15:23 CEST
Update
You also may experience a delay today in the Codabox bank statements for Crelan, Beobank, CPH and Bank van Breda. Please note that the Crelan statements from yesterday have been delivered. Codabox is currently investigating this issue. We will update this page as soon as more information becomes available.
Posted Sep 12, 2025 - 08:50 CEST
Investigating
You may experience a delay in the Codabox bank statements for Crelan. Codabox is currently investigating this issue. Our apologies for the inconvenience.