Exact Online - No statements delivered for PSD2 bank links (NL)
Incident Report for Exact System
Resolved
This issue has been resolved. Our apologies for the inconvenience.
Posted Aug 16, 2024 - 12:10 CEST
Investigating
You may experience that your bank statements are not delivered for your PSD2 bank link(s). We are further investigating this issue. We will update this page as soon as new information becomes available. Our apologies for the inconvenience.
Posted Aug 16, 2024 - 08:52 CEST
This incident affected: Bank links / PSD2.