Performance issues
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 08:30 CEST
Update
We are continuing to monitor for any further issues.
Posted Jul 30, 2020 - 08:30 CEST
Monitoring
The performance issues are no longer occurring we are monitoring the situation.
Posted Jul 29, 2020 - 18:05 CEST
Investigating
We are currently investigating this issue.
Posted Jul 29, 2020 - 15:23 CEST
This incident affected: United Kingdom (Accountancy, Accounting, Digital Mailbox, Manufacturing, Project Management, Scan & Recognize, Support department, Time & Billing, Wholesale Distribution, Exact API).