ING statements are not processed yet

Incident Report for Exact System

Resolved

The ING bank statements are processed. Our apologies for any inconvenience caused.
Posted Jul 27, 2022 - 09:37 CEST

Investigating

The ING bank statements are not processed yet. We are working hard to solve this as soon as possible. Our apologies for any inconvenience caused.
Posted Jul 27, 2022 - 08:34 CEST