Exact Cloud Services e-mail issue

Incident Report for Exact System

Resolved

This incident has been resolved.
Posted Mar 21, 2023 - 12:26 CET

Monitoring

The mail service has been restored, we are monitoring the solution
Posted Mar 21, 2023 - 12:12 CET

Update

The issue is limited to customers on our healthcare platform
Posted Mar 21, 2023 - 12:03 CET

Identified

We have identified the cause of the mail issue and are working on restoring the service. We expect a solution in the next 1,5 - 2 hours
Posted Mar 21, 2023 - 11:31 CET

Investigating

Currently you may experience an issue with e-mail exchange in the cloud environment
Posted Mar 21, 2023 - 11:20 CET
This incident affected: Exact Cloud Services.