Exact Online Premium - Performance issues Exact Online Premium (Global)

Incident Report for Exact System

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 22, 2025 - 14:59 CEST

Investigating

You may experience performance issues in Exact Premium through various menu paths. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted May 22, 2025 - 11:49 CEST
This incident affects: Exact Online Premium.