All Products - Support not reachable through phone (Global)

Incident Report for Exact System

Resolved

The issue has been resolved. Our support department is reachable again through all channels including phone. Our apologies for the inconvenience.
Posted Mar 31, 2025 - 09:59 CEST

Investigating

Currently we are facing technical issues with the Exact Support phone lines. As a result, you are not able to call Support at this moment. Please use our alternative support options to contact support on https://support.exact.com instead. Our apologies for the inconvenience.
Posted Mar 31, 2025 - 09:12 CEST
This incident affected: Customer Support Department.