Some of your documents might temporarily be unavailable.
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 22, 2019 - 09:40 CET
Update
We are continuing to monitor for any further issues.
Posted 7 months ago. Mar 20, 2019 - 17:48 CET
Monitoring
A fix has been implemented and we're monitoring the results.
Posted 7 months ago. Mar 20, 2019 - 17:48 CET
Identified
The issue has been identified and we're currently solving the issue.
Posted 7 months ago. Mar 20, 2019 - 10:55 CET
Investigating
We are currently investigating this issue.
Posted 7 months ago. Mar 19, 2019 - 18:35 CET