Exact Status Page

Exact Officient - Slowness while working in Officient (BE)

Incident Report for Exact System

Resolved

The environment has been optimized to improve performance and calendars can be pushed to the payroll provider.
Our apologies for the inconvenience.
Posted Apr 27, 2026 - 14:36 CEST

Investigating

You may experience slowness while working, and issues when pushing calendars to your payroll provider, in Officient.
We are investigating this issue. Our apologies for the inconvenience.
Posted Apr 27, 2026 - 11:00 CEST
This incident affected: Exact Officient.