Status

Exact Gripp - Exact Gripp currently unavailable (NL)

Incident Report for Exact System

Resolved

This issue has been resolved. Exact Gripp is available again. Our apologies for the inconvenience.
Posted Jan 28, 2026 - 13:59 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 28, 2026 - 13:54 CET

Investigating

Currently Exact Gripp is unavailable due to performance issues. We are working hard to solve this issue. As soon as an update becomes available we will update this page. Our apologies for the inconvenience.
Posted Jan 28, 2026 - 11:19 CET
This incident affected: Exact Gripp.