This issue has been resolved. Our apologies for the inconvenience.
Posted Apr 14, 2025 - 10:23 CEST
Monitoring
Emails sent from Exact Online are being delivered again, there might still be some delay. We are monitoring the situtation.
Posted Apr 14, 2025 - 09:25 CEST
Investigating
Email messages sent from Exact Online might currently not be delivered. This includes but is not limited to password reset e-mails and outgoing sales invoices and quotations. The messages do not have to be resent. We are investigating this issue. Our apologies for the inconvenience.
Posted Apr 14, 2025 - 09:01 CEST
This incident affected: Exact Online and Exact Online Premium.