Exact Status Page

Exact Reeleezee – Exact Reeleezee unavailable (NL)

Incident Report for Exact System

Resolved

The issue has been resolved. It is possible again to log in without delays. Our apologies for the inconvenience.
Posted Mar 04, 2026 - 09:23 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2026 - 08:57 CET

Investigating

Currently you may experience issues when logging in to Exact Reeleezee. A retry may solve the issue. We are investigating the issue. Our apologies for the inconvenience.
Posted Mar 04, 2026 - 08:33 CET
This incident affected: Exact Reeleezee.