All Products – Issues with PSD2 bank links (all banks) (NL – BE)

Incident Report for Exact System

Resolved

This issue has been resolved. All PSD2 bank links are working as intended again and delayed statements have been delivered. Our apologies for the inconvenience.
Posted Jun 21, 2025 - 08:49 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 20, 2025 - 10:07 CEST

Identified

The issue has been identified. Missing statements are now being imported with a delay.
Posted Jun 19, 2025 - 13:21 CEST

Investigating

It is possible that your PSD2 bank link is not working correctly. The issue may have impact on the automatic import of bank statements and the export of payment and direct debit files. We are investigating the issue. As soon as more information becomes available we will update this page. Our apologies for the inconvenience.
Posted Jun 18, 2025 - 09:08 CEST
This incident affected: Bank links / PSD2.