Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 18, 2025 - 04:00 CET
Scheduled
Exact Online Fiscal and Annual Reporting will be undergoing scheduled maintenance on Saturday the 18th of January between 04:00–10:00 CET. During this maintenance window, our systems will be temporarily unavailable. We apologize for any inconvenience this may cause and appreciate your understanding.
Posted Jan 15, 2025 - 15:33 CET
This scheduled maintenance affected: Exact Online Fiscaal and Exact Online Jaarrekening.