Exact Status Page

Exact Online Premium - Login page not accessible (NL)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Mar 31, 2026 - 14:45 CEST

Investigating

The login page for Exact Online Premium is currently not accessible. We are investigating the issue. Our apologies for the inconvenience.
Posted Mar 31, 2026 - 14:22 CEST
This incident affected: Exact Online Premium.