Exact Status Page

Exact Online - Purchase invoices do not come through to digital postbox (NL/BE)

Incident Report for Exact System

Resolved

This issue has been resolved and the purchase invoices that were sent have now been received in the digital postbox.
Posted Sep 01, 2026 - 13:18 CEST

Identified

The issue has been identified and the retrieval of sent messages has started.
Posted Sep 01, 2026 - 11:23 CEST

Investigating

You may experience that purchase invoices sent to the digital postbox are not received. Please refrain from resending to avoid duplicates. We are investigating this issue. This page will be updated as soon as more information becomes available. Our apologies for the inconvenience.
Posted Sep 01, 2026 - 10:27 CEST
This incident affected: Exact Online and Exact Online Premium.