This issue has been resolved. The annual reports have been filed with the Chamber of Commerce. In some cases you will have to re-submit the annual report to the Chamber of Commerce yourself. Our apologies for the inconvenience.
Posted Aug 12, 2025 - 12:20 CEST
Investigating
You might get an 'FVS500'-error while filing annual reports. The error message states that the submitted message does not meet the requirements. We are investigating this issue. Our apologies for the inconvenience.
Posted Jul 31, 2025 - 11:27 CEST
This incident affected: Exact Online Jaarrekening.