This issue has been resolved and the login page is available again. You might also have experienced performance issues before the login page was unavailable. Performance has also been restored. Our apologies for the inconvenience.
Posted Jun 17, 2026 - 12:42 CEST
Monitoring
We have implemented a fix and are monitoring the results. The Exact Online UK login page is available again.
Posted Jun 17, 2026 - 12:21 CEST
Investigating
You may experience that it is not possible to login at https://start.exactonline.co.uk/ as the page keeps loading and you eventually receive the error message: "Login page not available". We are investigating the issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.