This issue has been resolved. All customers who registered a support case with us with be reverted to the new project overview.
Posted Aug 06, 2025 - 14:27 CEST
Identified
The issue has been identified and we are working on a solution. As this issue only occurs in the new project overview we can temporarily restore your project overview so you can continue working with Exact Bouw. Therefore, please contact our support department if you run into this issue.
Posted Aug 01, 2025 - 16:43 CEST
Investigating
You may experience that the Projects overview page keeps loading and no Projects are shown. We are currently investigating this issue. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.