Exact Online Annual Reporting - The resubmission of annual reports are not received by the Chamber of Commerce (NL)

Incident Report for Exact System

Identified

This issue has been identified and we are currently working on a fix.
Posted Mar 21, 2025 - 20:02 CET

Investigating

The resubmission of annual reports may not be received by the Chamber of Commerce. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted Mar 21, 2025 - 20:01 CET
This incident affects: Exact Online Jaarrekening.