Exact Status Page

All products – Rabobank bank links outage (NL)

Incident Report for Exact System

Monitoring

Rabobank has implemented a fix and we are monitoring the results. For the Exact PSD2 link for Rabobank missing statements can be imported via the ‘import’ hyperlink in the financial dashboard. For the Rabo BoekhoudKoppeling, missing statements will be imported during the next retrieval moment. Rejected payments can be reopened and reprocessed again.
Posted Jul 06, 2026 - 14:48 CEST

Investigating

Due to an issue at the Rabobank, processing payments, receiving statements and creating or renewing bank links is not possible. The issue occurs both for the Rabo BoekhoudKoppeling and the Exact PSD2 bank link for Rabobank. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jul 06, 2026 - 10:41 CEST
This incident affects: Bank links / PSD2.