Exact Status Page

Exact Online - Blank line between orders to be picked (Global)

Incident Report for Exact System

Identified

The issue has been identified, we are currently working on a solution.
Posted Jul 23, 2026 - 16:43 CEST

Investigating

You may notice a blank line between the orders in the screen To be picked. We are investigating the issue at the moment and will keep you updated as soon as more information becomes available.
Our apologies for the inconvenience.
Posted Jul 23, 2026 - 09:30 CEST
This incident affects: Exact Online and Exact Online Premium.