This issue has been resolved and all missing statements are imported. Our apologies for the inconvenience.
Posted Jun 20, 2025 - 15:26 CEST
Identified
The bank statements are currently being imported.
Posted Jun 20, 2025 - 10:10 CEST
Investigating
It is possible that your bank statements have not been updated automatically with the statements of June 19th when using the ABN AMRO boekhoudkoppeling (1.0). Please note that not all bank links are affected and that the issue does not affect the Exact PSD2 link for ABN AMRO. We are currently investigating the issue. Our apologies for the inconvenience.