Exact Online - Not able to login to Exact Online (NL/BE/DE)

Incident Report for Exact System

Resolved

The issue has been resolved. Our apologies for the inconvenience.
Posted Nov 03, 2025 - 12:45 CET

Update

We are continuing to investigate this issue.
Posted Nov 03, 2025 - 10:54 CET

Update

We are continuing to investigate this issue.
Posted Nov 03, 2025 - 10:41 CET

Investigating

You may experience issues logging in to Exact Online. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Nov 03, 2025 - 10:25 CET
This incident affected: Exact Online, Exact Online Premium, and Exact Online Payroll & HR.