Performance issues in UK
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Sep 03, 2021 - 08:12 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 02, 2021 - 17:17 CEST
Investigating
We are currently investigating this issue.
Posted Sep 02, 2021 - 14:29 CEST
This incident affected: United Kingdom (Accountancy, Accounting, Digital Mailbox, Manufacturing, Project Management, Scan & Recognize, Support department, Time & Billing, Wholesale Distribution, Exact API).