Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 11, 2025 - 07:00 CEST
Scheduled
On Thursday, 11 September 2025, our colleagues will be attending Exact Day to learn more in order to provide you with even better support. Our support team will not be available on that day. If you need help, you can ask your questions to the Exact Assistant, which is available 24/7 to assist you. Our support team will be back to assist you on Friday, 12 September 2025.
Posted Sep 10, 2025 - 09:49 CEST
This scheduled maintenance affected: Customer Support Department.