Reeleezee - Bank transactions via the Rabobank link may have been delayed since Sunday February the 12th.
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Feb 16, 2023 - 13:57 CET
Investigating
We are currently investigating this issue.
Posted Feb 13, 2023 - 13:18 CET
This incident affected: Reeleezee - Accounting - Accountancy portal - Cashr.