This issue has been resolved. Our apologies for the inconvenience.
Posted Jun 14, 2025 - 17:30 CEST
Identified
We are currently experiencing that our general website is not accessible .This is included but not limited to exact.nl, exact.be and exact.com. As a workaround you can directly go to the login pages such as start.exactonline.nl or start.exactonline.be to access your license. Our apologies for the inconvenience.
Posted Jun 14, 2025 - 16:32 CEST
This incident affected: Exact Online and Exact Online Premium.