This issue has been resolved. Our apologies for the inconvenience.
Posted Sep 09, 2026 - 10:17 CEST
Monitoring
We have implemented a fix and logging in is possible again. We are monitoring the results.
Posted Sep 09, 2026 - 09:31 CEST
Identified
We have identified the issue and are implementing a fix.
Posted Sep 09, 2026 - 09:13 CEST
Investigating
You may get an error ‘504 Gateway Time-out' when logging into Exact Online Fiscaal. We are investigating the issue. This page will be updated as soon as more information becomes available. Our apologies for the inconvenience.