Not possible to start company screening PSD2 (NL)
Incident Report for Exact System
Resolved
The issue has now been resolved. The company screening can be started again. After the screening has been executed, you can immediately continue with creating a PSD2 bank link. Apologies for the inconvenience.
Posted Sep 14, 2023 - 08:18 CEST
Investigating
The UBO's are not shown when starting the company screening. Therefore, it is currently not possible to start the company screening in order to create a PSD2 connection. We are currently investigating this issue. Apologies for the inconvenience.
Posted Sep 12, 2023 - 17:13 CEST