We are still investigating the impacted invoices. You can resubmit the declined invoices if needed.
Posted Dec 19, 2025 - 16:48 CET
Monitoring
A fix has been implemented. Errors were given between 11:53 and 13.50 19/12. We are monitoring the results. Please refrain from resending the affected invoices until further notice.
Posted Dec 19, 2025 - 14:38 CET
Investigating
You may experience that the Track status 'Error' is given for sales invoices that were sent via Peppol starting today at 11:45. You will also receive an email stating: This invoice could not be delivered please contact support. Participant data for PartitionKey: 9925:BEXXX; and RowKey: EolBe not found. We are investigating this issue. Our apologies for the inconvenience.
Posted Dec 19, 2025 - 13:54 CET
This incident affects: Exact Online and Exact Online Premium.