This issue has been resolved. Our apologies for the inconvenience.
Posted Aug 06, 2025 - 14:53 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2025 - 16:41 CEST
Investigating
You may experience that your automations in Exact Online Premium are executed with a delay. We are currently investigating this issue. Please be advised that the re-triggering of the delayed automation has no effect. Once an update is available we will upload this page. Our apologies for the inconvenience.