Exact Cloud Services - Hosted desktop does not start (Global)

Incident Report for Exact System

Resolved

The issue has been resolved. Our apologies for the inconvenience.
Posted 4 days ago. Mar 31, 2025 - 13:19 CEST

Monitoring

The hosted desktop can be reached again. As many employees will now start to login simultaneously you may experience temporary performance degradation. We are monitoring the situation.
Posted 4 days ago. Mar 31, 2025 - 11:33 CEST

Investigating

At this moment you may experience that the hosted desktop does not start, we are working on a fix for this issue. We will provide a status update here as soon as possible. Our apologies for the inconvenience.
Posted 4 days ago. Mar 31, 2025 - 10:06 CEST
This incident affected: Exact Cloud Services.