EOL - Support currently unavailable via phone (NL)
Incident Report for Exact System
Resolved
The issue has been resolved. Our support department is fully available via phone again.
Posted Jun 05, 2023 - 10:12 CEST
Monitoring
Our support department is available via phone again. We are monitoring the situation.
Posted Jun 05, 2023 - 09:13 CEST
Investigating
It is possible when you try to call support your call won't come through. Our chatfunctionality is still available. We are working hard to solve this issue. Our apologies for the inconvenience.
Posted Jun 05, 2023 - 09:05 CEST