This issue has been resolved. All statements have been delivered. Our apologies for the inconvenience
Posted Aug 28, 2025 - 08:46 CEST
Monitoring
We have implemented a fix and we are monitoring the results, We will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Aug 27, 2025 - 08:50 CEST
Investigating
The bank statements for the ING 1.0 bank link are not delivered yet. ING PSD2 bank links are not affected. We are investigating this issue. Our apologies for the inconvenience.