This issue has been resolved. Our apologies for the inconvenience.
Posted Aug 20, 2026 - 10:04 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2026 - 09:02 CEST
Identified
The issue has been identified. We are working on a fix.
Posted Aug 18, 2026 - 15:43 CEST
Update
We are still investigating this issue.
Posted Aug 18, 2026 - 15:02 CEST
Investigating
You may experience a degraded performance and longer loading times in Exact Online Premium. We are investigating this issue and will update this page as soon as more information becomes available. Our apologies for the inconvenience.