Exact Online - Not possible to complete company screening or Peppol registration via itsme (BE)

Incident Report for Exact System

Resolved

This issue has been resolved and itsme is working as intended again. Company screenings and Peppol registrations can therefore be completed again. Our apologies for the inconvenience.
Posted Dec 10, 2025 - 12:12 CET

Identified

Due to an outage at itsme, it is currently not possible to complete the company screening. Please note: the Peppol registration can also be completed through a €0.01 payment. itsme is actively working on a solution to resolve the issue as soon as possible. Our apologies for the inconvenience.
Posted Dec 10, 2025 - 10:45 CET
This incident affected: Exact Online.