Exact Online Fiscaal -Subscription changes are not displayed in Exact online fiscaal (NL)

Incident Report for Exact System

Resolved

The issue has been resolved. Our apologies for the inconvenience.
Posted Apr 25, 2025 - 11:25 CEST

Investigating

You may experience issues with changing the subscription for Exact Online Fiscaal. Changes made in the subscription on start.exactonline.nl are not visible on start.fiscaalgemak.nl. We are investigating these issues and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Apr 25, 2025 - 10:41 CEST
This incident affected: Exact Online Fiscaal.