Exact Online HR + Officient - Mobile app not available in Android Play store
Incident Report for Exact System
Resolved
This issue has been resolved, and the app is available in the play store again. Apologies for the inconvenience.
Posted Nov 27, 2024 - 09:55 CET
Investigating
The Exact Online HR and Officient apps are currently not available in the Android Play store. You can still access the Self Service in the browser through selfservice.officient.io. We are working hard to solve this issue. Our apologies for the inconvenience.
Posted Nov 15, 2024 - 17:53 CET
This incident affected: Exact Online and Exact Officient.