Exact Online - Not possible to complete Peppol registration if you are not the legal representative and not logged in to Exact Online (NL/BE)

Incident Report for Exact System

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 24, 2025 - 16:52 CEST

Investigating

It's not possible to complete the Peppol registration if you are not the legal representative and select the option to e-mail the legal representative to approve the registration. We have identified the issue and are currently working on a fix. In the meantime the legal representative can login via Exact Online if they have an user and finalize the registration. Our apologies for the inconvenience.
Posted Jun 20, 2025 - 09:28 CEST
This incident affects: Exact Online and Exact Online Premium.