Exact Reeleezee - Reeleezee is not available (NL)
Incident Report for Exact System
Resolved
Exact Reeleezee is available and connectivity is stable.
Posted Jun 29, 2024 - 17:31 CEST
Investigating
Exact Reeleezee is currently not available. When trying to log in, the login page is not available. We are working on a solution. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jun 29, 2024 - 11:32 CEST
This incident affected: Exact Reeleezee.