Opening an account card may cause performance issues
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Oct 24, 2019 - 10:34 CEST
Investigating
We are currently investigating this issue.
Posted Oct 24, 2019 - 09:27 CEST
This incident affected: Netherlands (Boekhouden, Uren & Facturen, Project Management, Handel, Productie, Accountancy).