Exact Status Page

Exact Venice - Issues retrieving incoming PEPPOL invoices (BE)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Mar 26, 2026 - 16:38 CET

Identified

You may encounter an issue where requests for incoming PEPPOL invoices may fail. Some invoices may be retrieved successfully, but subsequent attempts can result in a 500 error. We have identified the issue and are working on implementing a fix. Our apologies for the inconvenience.
Posted Mar 25, 2026 - 15:46 CET
This incident affected: Exact Venice.