This issue has been resolved. Newly created clients are visible again in the client overview. Clients that you created and that were not immediately visible are also be visible now. Our apologies for the inconvenience.
Posted Sep 15, 2025 - 11:58 CEST
Investigating
You may experience that newly created clients are not always visible in the client overview, while the client is successfully created. We are investigating this issue. You can copy and save the URL after creating the client and paste as URL if you need to view the client In the meantime. Our apologies for the inconvenience.
Posted Sep 15, 2025 - 10:09 CEST
This incident affected: Exact Online Fiscaal and Exact Online Jaarrekening.